FTP errors winsock 10053

Technical support and scripting issues

Moderators: Dorian (MJT support), JRL

Post Reply
chihuahualand
Junior Coder
Posts: 35
Joined: Thu Jan 12, 2006 9:20 pm
Contact:

FTP errors winsock 10053

Post by chihuahualand » Thu Sep 07, 2006 6:55 pm

I'm running a ftp server (FileZilla server).
I'm getting 500 Winsock Error 10053 on various FTP operations... on a FtpPutFile for example, but the server log show all A-Ok... and the file is on the server...

passive mode seems to have no effect.

any ideas?

chihuahualand
Junior Coder
Posts: 35
Joined: Thu Jan 12, 2006 9:20 pm
Contact:

Post by chihuahualand » Thu Sep 07, 2006 7:35 pm

More info...

The exact FTP_STATUS message.

500 Control connection closed. Connection aborted (Winsock error #10053)

It will ultimately succeed, if I hammer at it... essentially, loop until the command is successful... perhaps 20-200 tries...

User avatar
JRL
Automation Wizard
Posts: 3357
Joined: Mon Jan 10, 2005 6:22 pm
Location: Iowa

Post by JRL » Thu Sep 07, 2006 7:47 pm

I don't think I can help you, I have no FTP servers to play with, but I still have a question.

In your first post you said the file exists on the server even though you get an error message.

In your second post you say that it works if you "hammer at it".

Are you putting the file on the server by looping repeatedly or are you not getting the error message by looping repeatedly?

Good luck,
Dick

chihuahualand
Junior Coder
Posts: 35
Joined: Thu Jan 12, 2006 9:20 pm
Contact:

Post by chihuahualand » Thu Sep 07, 2006 9:45 pm

I try to FtpPutFile, if I get an error, I repeat, eventually FTP_RESULT=Success. The server log show that the file has been sent successfully (STOR) a zillion times... and that the server sent back a "success" code a zillion times...

Me_again
Automation Wizard
Posts: 1101
Joined: Fri Jan 07, 2005 5:55 pm
Location: Somewhere else on the planet

Post by Me_again » Thu Sep 07, 2006 9:59 pm

I also have a filezilla server and have no problem with the combination of mjt's ftp and filezilla ftp server. As a test I just ran an n=200 loop using passive/ftpputfile to send a 400K file to that server, I wrote FTP_RESULT to a file and have zero errors.

Are you saying to are seeing fewer success FTP_RESULTS than the fileserver is saying it got files?

If you are not seeing errors in the filezilla log it's most likely because the failed attempts were really something like network failures to establish any connection to filezilla. FTP_RESULT isn't very informative, if you search the forum for "proxy" you'll see a recent thread where Marcus posted a suggestion for getting a full ftp log, or you could try using a regular ftp scripting approach that would enable you to get a full log of the event.

chihuahualand
Junior Coder
Posts: 35
Joined: Thu Jan 12, 2006 9:20 pm
Contact:

Post by chihuahualand » Tue Sep 12, 2006 11:02 pm

... further testing reveals that Windows Firewall is partly (completely) to blame. Turn it off, everything works flawlessly. Turn it on, and almost everytime macro ftp commands yield "500 Control connection closed"instead of "Success" (the command did seems to perform successfully despite the error message in the FTP_RESULT)

So I give in...

I'm gonna add a
"netsh firewall set opmode disable" to turn off the windows firewall and
"netsh firewall set opmode enable" when done...

-thanks y'all.

Post Reply
Sign up to our newsletter for free automation tips, tricks & discounts