Error [HTTP / 1.1 404 Not Found] in chromedriver

Hints, tips and tricks for newbies

Moderators: Dorian (MJT support), JRL

Post Reply
thiagunix
Newbie
Posts: 16
Joined: Tue May 05, 2020 2:16 pm

Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by thiagunix » Mon May 25, 2020 4:57 pm

My macro using chrome has stopped working and is showing the error [HTTP / 1.1 404 Not Found].

I have already reinstalled Macro Scheduler and chromedriver and the error continues.

I know that the problem occurs because the macro scheduler tries to send the url to chrome and it does not find and the error.

The chromedriver opens and closes quickly. Has anyone had this problem?

My Macro

Code: Select all

Let>CHROMEDRIVER_EXE=C:\chromedriver\chromedriver.exe

//start a chrome session
ChromeStart>session_id

//navigate to google.com
ChromeNavigate>session_id,url,https://www.google.com/

//get some info 
ChromeGetInfo>session_id,url,theURL
ChromeGetInfo>session_id,title,theTitle
ChromeGetInfo>session_id,source,theSource

//we can go back and forward ... 
ChromeNavigate>session_id,back,
ChromeNavigate>session_id,forward,
Thanks

marvinstone
Newbie
Posts: 2
Joined: Mon May 25, 2020 7:44 pm

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by marvinstone » Mon May 25, 2020 8:53 pm

I'm brand new to Macro Scheduler and have the same problem. I followed all of the same steps you did - twice - and still getting the same exact error. I just haven't gotten around to posting about it yet to look for a solution.

(I then tried webrecorder but had different issues)

User avatar
Marcus Tettmar
Site Admin
Posts: 7270
Joined: Thu Sep 19, 2002 3:00 pm
Location: Dorset, UK
Contact:

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by Marcus Tettmar » Tue May 26, 2020 10:06 am

One or two people have mentioned this and it's either gone away or remained a mystery. I've never been able to replicate a similar problem.

Check if ChromeDriver is running in task manager. If so Kill it. Now run it MANUALLY. You should see some info on the console. Now run the script - it will use the ChromeDriver you just started manually. The ChromeDriver console will hopefully give you more info.
Marcus Tettmar
http://mjtnet.com/blog/ | http://twitter.com/marcustettmar

Did you know we are now offering affordable monthly subscriptions for Macro Scheduler Standard?

thiagunix
Newbie
Posts: 16
Joined: Tue May 05, 2020 2:16 pm

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by thiagunix » Tue May 26, 2020 2:30 pm

The server is running without a problem, but my machine stopped working

Return execute console

Code: Select all

C:\chromedriver>chromedriver.exe
Starting ChromeDriver 81.0.4044.69 (6813546031a4bc83f717a2ef7cd4ac6ec1199132-refs/branch-heads/[email protected]{#776}) on port 9515
Only local connections are allowed.
Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code.
Thanks

thiagunix
Newbie
Posts: 16
Joined: Tue May 05, 2020 2:16 pm

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by thiagunix » Thu May 28, 2020 12:55 pm

It was working normally on my server yesterday.

Today I ran the routine and started giving the same error.

Opens the chromedriver and closes quickly.
Error na execução vi
Error when running chromedriver on cmd

Code: Select all

Please protect ports used by ChromeDriver and related test frameworks to prevent
 access by malicious code.
[1590669190.980][SEVERE]: bind() returned an error: Only one usage of each socke
t address (protocol/network address/port) is normally permitted. (0x2740)
IPv6 port not available. Exiting...
On the server the error message is different
Exception EldHTTPProtocolException in module msched.exe at 002BE490.
HTTP / 1.1 404 Not Found

This server has been running for more than 2 weeks normally every day. Today I went in to check and ran the routine and it gave an error.

Do you have any tips?
Thanks

User avatar
Marcus Tettmar
Site Admin
Posts: 7270
Joined: Thu Sep 19, 2002 3:00 pm
Location: Dorset, UK
Contact:

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by Marcus Tettmar » Thu May 28, 2020 1:20 pm

Sounds like the port is in use. Maybe ChromeDriver is already running, or something else has the port open. Try rebooting and/or you can set a different port by setting CHROMEDRIVER_PORT prior to calling ChromeStart.
Marcus Tettmar
http://mjtnet.com/blog/ | http://twitter.com/marcustettmar

Did you know we are now offering affordable monthly subscriptions for Macro Scheduler Standard?

thiagunix
Newbie
Posts: 16
Joined: Tue May 05, 2020 2:16 pm

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by thiagunix » Thu May 28, 2020 2:56 pm

Even error

Code: Select all

Let>CHROMEDRIVER_EXE=C:\chromedriver\chromedriver.exe
Let>CHROMEDRIVER_PORT=8585

//start a chrome session
ChromeStart>session_id

//navigate to google.com
ChromeNavigate>session_id,url,https://www.google.com/

//get some info 
ChromeGetInfo>session_id,url,theURL
ChromeGetInfo>session_id,title,theTitle
ChromeGetInfo>session_id,source,theSource
Thanks

User avatar
Marcus Tettmar
Site Admin
Posts: 7270
Joined: Thu Sep 19, 2002 3:00 pm
Location: Dorset, UK
Contact:

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by Marcus Tettmar » Thu May 28, 2020 3:04 pm

Are you sure that port is free?

https://stackoverflow.com/questions/418 ... is-normall

This is definitely a network issue - either the port is unavailable or the firewall is blocking it. Might want to search the ChromeDriver support site.
Marcus Tettmar
http://mjtnet.com/blog/ | http://twitter.com/marcustettmar

Did you know we are now offering affordable monthly subscriptions for Macro Scheduler Standard?

hagchr
Macro Veteran
Posts: 277
Joined: Mon Jul 05, 2010 7:53 am
Location: Stockholm, Sweden

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by hagchr » Sat May 30, 2020 8:58 am

I suddenly got the same problem today. Following the suggestion, I started ChromeDriver manually (as Administrator), ran the script and it started to work again.

Not sure if relevant or not, before running the script I also commented out
//Let>CHROMEDRIVER_EXE=c:\chromedriver.exe
got a warning, but it ran ok. Then I removed // and it seems to work fine now.

thiagunix
Newbie
Posts: 16
Joined: Tue May 05, 2020 2:16 pm

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by thiagunix » Tue Jun 23, 2020 1:41 pm

I can't get it to work.

I tested with Edge the same problem happens.

NickD
Pro Scripter
Posts: 55
Joined: Fri Sep 23, 2016 2:17 pm

Re: Error [HTTP / 1.1 404 Not Found] in chromedriver

Post by NickD » Tue Jul 28, 2020 3:07 pm

I had the same issue, in my case it was due to the fact that chrome browser had been updated to a newer version, therefore the version of ChromeDriver in my script folder was no longer compatible.

Visit chrome://version/ in your browser to see your chrome version number, then visit https://chromedriver.chromium.org/downloads to grab the ChromeDriver version for your current Chrome installation.

Post Reply
Sign up to our newsletter for free automation tips, tricks & discounts