Let>NumFound=0 Fails

Technical support and scripting issues

Moderators: Dorian (MJT support), JRL

Post Reply
fightcancer
Macro Veteran
Posts: 193
Joined: Fri Apr 15, 2005 8:32 am

Let>NumFound=0 Fails

Post by fightcancer » Thu Sep 16, 2021 4:18 am

I've got a couple thousand lines of code, but when I reach this line:

Let>NumFound=0

...the Watch List shows this result:

0: NUMFOUND=1

Wondering what might prevent MS from assigning the value zero to the var NumFound.

Thanks!

User avatar
Grovkillen
Automation Wizard
Posts: 766
Joined: Fri Aug 10, 2012 2:38 pm
Location: Hudiksvall, Sweden
Contact:

Re: Let>NumFound=0 Fails

Post by Grovkillen » Thu Sep 16, 2021 5:51 am

Do you have a variable "0" set to "1" perhaps?
Let>ME=%Script%

Running: 15.0.19b
version history

fightcancer
Macro Veteran
Posts: 193
Joined: Fri Apr 15, 2005 8:32 am

Re: Let>NumFound=0 Fails

Post by fightcancer » Thu Sep 16, 2021 2:51 pm

Yes, that was the issue. I had no idea that MS would allow me to do it! I have a lot to learn....

Thanks so much!

User avatar
Dorian (MJT support)
Automation Wizard
Posts: 972
Joined: Sun Nov 03, 2002 3:19 am
Contact:

Re: Let>NumFound=0 Fails

Post by Dorian (MJT support) » Thu Sep 16, 2021 4:29 pm

We've all done it at some point.
Yes, we have a Custom Scripting Service. Message me or go here

User avatar
Grovkillen
Automation Wizard
Posts: 766
Joined: Fri Aug 10, 2012 2:38 pm
Location: Hudiksvall, Sweden
Contact:

Re: Let>NumFound=0 Fails

Post by Grovkillen » Thu Sep 16, 2021 7:14 pm

Yep, that's why we ask.... Because we've been there, done that :)
Let>ME=%Script%

Running: 15.0.19b
version history

Post Reply
cron
Sign up to our newsletter for free automation tips, tricks & discounts