Search found 10 matches

by shadowesq
Thu Jul 02, 2020 5:12 pm
Forum: Technical / Scripting
Topic: WaitWindowOpen and IfWindowOpen Failures
Replies: 2
Views: 675

WaitWindowOpen and IfWindowOpen Failures

I've been building a new macro using the Chrome Driver, which is incredibly cool. However, I have bumped into a new problem. It seems that the WaitWindowOpen and IfWindowOpen commands are failing to detect the presence of the open window. My theory would be that somehow the Chrome Driver window has ...
by shadowesq
Thu Jul 02, 2020 3:52 pm
Forum: Technical / Scripting
Topic: ChromeFindElements & ChromeGetElementData
Replies: 5
Views: 976

Re: ChromeFindElements & ChromeGetElementData

Dear Marcus, Thank you! It worked!!! I struggled with the code for another hour, because no matter what I tried, the ChromeFindElements command was not returning any values to me. But then I stumbled upon the css selector option, and I gave that a try. Sure enough, the ChromeFindElements returned a ...
by shadowesq
Wed Jul 01, 2020 5:09 pm
Forum: Technical / Scripting
Topic: ChromeFindElements & ChromeGetElementData
Replies: 5
Views: 976

Re: ChromeFindElements & ChromeGetElementData

Thank you Marcus!

I will take a look to see if (1) I can get the data I need without reference to the <a> tag and (2) if those new features you mentioned will help me out.

Regards,

Chris
by shadowesq
Mon Jun 29, 2020 5:23 am
Forum: Technical / Scripting
Topic: ChromeFindElements & ChromeGetElementData
Replies: 5
Views: 976

Re: ChromeFindElements & ChromeGetElementData

Here is the other photo which did not seem to load....
smxpathscrren1.jpg
smxpathscrren1.jpg (196.78 KiB) Viewed 974 times
by shadowesq
Mon Jun 29, 2020 5:18 am
Forum: Technical / Scripting
Topic: ChromeFindElements & ChromeGetElementData
Replies: 5
Views: 976

ChromeFindElements & ChromeGetElementData

I'm having some problems getting these two commands to work together. Here is the issue. I execute the ChromeFindElements command thusly: ChromeFindElements>session_id,xpath,/html/body/form/div[3]/div[2]/table/tbody/tr/td/div[2]/div/div[3]/table/tbody/tr/td[1]/div/div/table/tbody/tr[1]/td/table/tbod...
by shadowesq
Tue Apr 14, 2020 5:52 pm
Forum: Technical / Scripting
Topic: Script hangs on child IE window
Replies: 26
Views: 16853

Re: Script hangs on child IE window

Hello all. Well, even though this thread is some six years old, the fun continues in 2020. I have a script which is hanging on the IEWaitNew>0,IE[1] command. There is a pdf page in the child window. The script opens the new window perfectly. However, after that, the script hangs on the IEWaitNew com...
by shadowesq
Fri Mar 20, 2020 2:57 pm
Forum: Technical / Scripting
Topic: When is a window not a window? When it won't CLOSE!
Replies: 2
Views: 450

Re: When is a window not a window? When it won't CLOSE!

Thank you Marcus,
I will give those suggestions a try. Right now I am forced to close the window with a MouseMove and LClick, not the most elegant solution....
by shadowesq
Tue Mar 17, 2020 2:52 am
Forum: Technical / Scripting
Topic: When is a window not a window? When it won't CLOSE!
Replies: 2
Views: 450

When is a window not a window? When it won't CLOSE!

Hey guys, I am tearing my hair out trying to solve what should be a simple problem. I recently decided to use Internet Explorer instead of Google Chrome for one of my macros. However, things are not working out quite right. When I run the macro, it starts up Internet Explorer and navigates to the co...
by shadowesq
Sat Feb 08, 2020 10:18 pm
Forum: Technical / Scripting
Topic: Problem with WaitWindowOpen
Replies: 3
Views: 458

Re: Problem with WaitWindowOpen

That code is in the beginning of my script, and I did not set WW_TIMEOUT at all. My reading of the documentation is that the default value of WW_TIMEOUT is zero, meaning that the script will wait forever for the window to open before processing continues.

Thanks for replying! I'm new here!
by shadowesq
Sat Feb 08, 2020 1:05 am
Forum: Technical / Scripting
Topic: Problem with WaitWindowOpen
Replies: 3
Views: 458

Problem with WaitWindowOpen

I am having a problem getting the WaitWindowOpen feature to behave. I use Google Chrome. When Chrome starts on my computer, my Google Calendar is my default page, so it will load first when Chrome is started. My problem is that when the code executes, it starts Chrome, but instead of waiting for the...
Sign up to our newsletter for free automation tips, tricks & discounts